当前位置:编程学习 > C/C++ >>

HDU 4763 Theme Section

Theme Section
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 179    Accepted Submission(s): 73
 
 
Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.
 
To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 
 
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 
 
Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 
 
Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa
 
 
Sample Output
0
0
1
1
2
 
 
Source
2013 ACM/ICPC Asia Regional Changchun Online
 
 
Recommend
liuyiding
 
思路 :二分+KMP;
 
#include <iostream>  
#include <cstring>  
#include <cstdio>  
#include <cmath>  
#define N 1000010  
using namespace std;  
char s1[N],s2[N];  
int len,next[N],sta;  
int main()  
{  
    //freopen("data.in","r",stdin);  
    int binary_search(int l,int r);  
    void get_next(int l);  
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%s",s1);  
        len =strlen(s1);  
        int l = 1;  
        int r = len/3;  
        for(int i=0;i<=r-1;i++)  
        {  
            s2[i] = s1[i];  
        }  
        s2[r]='\0';  
        get_next(r);  
        int i=0,j=len-r;  
        while(j<=len-1)  
        {  
            if(i==-1||s1[i]==s1[j])  
            {  
                i++;  
                j++;  
            }else if(s1[i]!=s1[j])  
            {  
                i = next[i];  
            }  
            if(i==r)  
            {  
                break;  
            }  
        }  
        if(i<=0)  
        {  
            printf("0\n");  
            continue;  
        }  
        sta = len-i;  
        r = i;  
        int k=binary_search(l,r);  
        printf("%d\n",k);  
    }  
    return 0;  
}  
void get_next(int l)  
{  
    next[0]=-1;  
    next[1]=0;  
    int j=0;  
    for(int i=2;i<=l;)  
    {  
        if(j==-1||s2[i-1]==s2[j])  
        {  
            i++;  
            j++;  
             if(s2[i-1]==s2[j])  
             {  
                 next[i-1]=next[j];  
              }else  
              {  
                next[i-1]=j;  
              }  
        }else  
        {  
            j= next[j];  
        }  
    }  
}  
int check(int l)  
{  
    get_next(l);  
    int j = l;  
    int i = 0;  
    bool ok=false;  
    while(j<=len-1)  
    {  
        if(i==-1||s2[i]==s1[j])  
        {  
            i++;  
            j++;  
        }else if(s2[i]!=s1[j])  
        {  
            i = next[i];  
        }  
        if(i==l)  
        {  
            ok=true;  
            break;  
        }  
    }  
    if(!ok)  
    {  
        return 0;  
    }  
    if(j-1>=sta)  
    {  
        return 0;  
    }else  
    {  
        return 1;  
    }  
}  
int binary_search(int l,int r)  
{  
    int pos = 0;  
    while(l<=r)  
    {  
        int mid = (l+r)/2;  
        for(int i=1;i<=mid;i++)  
        {  
            s2[i-1] = s1[i-1];  
        }  
        s2[mid] = '\0';  
        int t=check(mid);  
        if(t==1)  
        {  
            pos = mid;  
            l=mid+1;  
        }else  
        {  
            r = mid-1;  
        }  
    }  
    return pos;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,