当前位置:编程学习 > C/C++ >>

字符串系列——10010 Where's Waldorf?

 
  Where's Waldorf? Given a m by n grid of letters, ( ), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.
Input 
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input begins with a pair of integers, m followed by n,  in decimal notation on a single line. The next m lines contain nletters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( ). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).
Output 
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.
Sample Input 
 1
 
8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert
Sample Output 
 2 5
2 3
1 2
7 8
 
算是寒假后续刷题那套的后续吧。。。
输入量太大调试令人蛋疼,今后得用些方法解决调试问题,现在时间急不想搞。。。
利用一个特长的函数来判断位置非常郁闷,所谓懒婆娘的裹脚布,调试了一下午终于正常了。
代码如下(非Ac):
[cpp]  
#include<stdio.h>  
#include<string.h>  
#include<ctype.h>  
  
int i, j, l,cnt, n, m, k, rec_m, rec_n;  
char letter[50][50], word[20][50], temp[50];  
  
int search(void);  
int main()  
{  
    scanf("%d", &cnt);  
  
    while (cnt --)  
    {  
        scanf("%d%d", &m, &n);  
        for (i = 0; i < m; i ++)  
        {  
            scanf("%s", letter[i]);  
            for (j = 0; j < strlen(letter[i]); j ++)  
                letter[i][j] = tolower(letter[i][j]);  
        }  
        scanf("%d", &k);  
        for (i = 0; i < k; i ++)  
        {  
            scanf("%s", word[i]);  
            for (j = 0; j < strlen(word[i]); j ++)  
                word[i][j] = tolower(word[i][j]);  
        }  
        for (i = 0; i < k; i ++)  
        {  
            search();  
            printf("%d %d\n", rec_n + 1, rec_m + 1);  
        }  
    }  
    return 0;  
}  
  
int search(void)  
{  
    int len = strlen(word[i]);  
    for (j = 0; j < m; j ++)  
    {  
        for (l = 0; l < n; l ++)  
        {  
            if (word[i][0] == letter[j][l])  
            {  
                if (l + len <= n)  
                {  
                    if (j - len + 1 >= 0)  
                    {  
                        //ru  
                    memset(temp, 0, sizeof(temp));  
                        for (int p = 0; p < len; p++)  
                            temp[p] = letter[j + p][l - p];  
                        if (strcmp(temp, word[i]) == 0)  
                        {  
                            rec_n = j;  
                            rec_m = l;  
                            return 0;  
                        }  
                    }  
                    if (j + len <= m)  
                    {  
                        //rd  
                    memset(temp, 0, sizeof(temp));  
        &
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,