当前位置:编程学习 > C/C++ >>

HDU1009 FatMouse' Trade

                FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33703    Accepted Submission(s): 10981

 

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 


Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 


Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 


Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output
13.333
31.500


Author
CHEN, Yue
 


Source
ZJCPC2004
 


Recommend
JGShining


解题思路:本题为典型贪心算法题目,由于物品可分割,不能用01背包做。
      先对给出的各个仓库的信息(豆子量,所需猫粮量)进行分析,可知仓库中豆子越多,所需猫粮越少,则越划得来,兑换该房间的豆子可以得到最大的豆子量。
      因此,先求出各个仓库的豆子量/所需猫粮量的比值(简称比值),比值大的应该考虑优先兑换。
      然后将所有仓库信息按照比值从大到小排序,得出各仓库的兑换先后顺序,存储在结构体数组food[]里面,准备兑换。
      然后按排序结果对相应仓库进行兑换,若当前所剩猫粮量不为0并且还有仓库未进行兑换,则继续兑换,
                (1)如果当前老鼠剩下的猫粮大于兑换当前仓库所有的豆子的所需的猫粮量,则兑换该仓库的所有豆子,豆子总量增加该仓库总豆子量的值,所剩猫粮总量减去兑换当前仓库所有豆子所需猫粮量;
                (2)如果当前老鼠剩下的猫粮小于兑换当前仓库所有的豆子的所需的猫粮量,则兑换该仓库的所有豆子*所剩猫粮/所需的猫粮量,豆子总量增加所有豆子*所剩猫粮/所需的猫粮量(注意精度,这里的值可能会产生小数),所剩猫粮总量置0;
       最后,按题目要求输出兑换所得豆子总量(保留3位小数)即可。


 

include<stdio.h>   
#include<algorithm>   
using namespace std;  
struct node  
{  
    int j;  
    int f;  
    double bi;  
}food[1005]; //兑换情况,豆子量,所需猫粮,豆/猫比   
bool cmp(node a,node b)    //排序,按比例从大到小排序   
{  
    return a.bi>b.bi;  
}  
int main()  
{  
    int m,n;  
    int i,j;  
    while(scanf("%d%d",&m,&n)&&(n!=-1||m!=-1))  
    {  
        for(i=0;i<n;i++)  
        {  
            scanf("%d%d",&food[i].j,&food[i].f);  
            food[i].bi=(double)food[i].j/food[i].f;  
        }  
        sort(food,food+n,cmp);  
        double sum=0;  
        i=0;  
        while(m&&i<n)   //当猫粮还有,豆子没有兑换完时,继续兑换   
        {  
            if(m>=food[i].f)  //若当前猫粮能兑换当前仓库所有豆子,则全部兑换   
            {  
                sum+=food[i].j;  
                m-=food[i].f;  
            }  
            else   //若当前猫粮无法兑换当前仓库所有猫粮,则按比例兑换   
            {  
                sum+=(double)m/food[i].f*food[i].j;  //注意精度哦   
                m=0;  //猫粮用完了   
            }  
            i++;  //下一个房间(已按豆/猫比排序)比例不大于已兑换房间,且不小于所有未兑换的房间   
        }  
        printf("%.3lf\n",sum);  
    }  
    return 0;  
}  

 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,