当前位置:编程学习 > C/C++ >>

UVA 571(数论)

 
  Jugs 
In the movie ``Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.
 
You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.
 
A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are
fill A
fill B
empty A
empty B
pour A B
pour B A
success
where ``pour A B" means ``pour the contents of jug A into jug B", and ``success" means that the goal has been accomplished.
 
You may assume that the input you are given does have a solution.
Input 
Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and Nis the goal. You can assume $0 < Ca \le Cb$ and $N \le Cb \le 1000$ and that A and B are relatively prime to one another.
Output 
Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line ``success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.
Sample Input 
3 5 4
5 7 3
Sample Output 
fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success
题意:给定两个容器容量Ca,Cb,和一个要倒出的水量N。要求倒水步骤。
思路:本来还以为是隐式图倒水,后来发现没说要最优情况啊。。而且题目中给定的Ca,Cb互质,并且N小于Cb。。这样一来肯定能倒出水的。
至于步骤只要不断把A倒满,倒到B,B满了就倒掉。这样反复一直倒,迟早会倒出对应的水量。
代码:
 
#include <stdio.h>  
  
int Ca, Cb, N, Na, Nb;  
  
int main() {  
    while (~scanf("%d%d%d", &Ca, &Cb, &N)) {  
        Na = Nb = 0;  
        while (Nb != N) {  
            if (Na == 0) {  
                Na = Ca;  
                printf("fill A\n");  
            }  
            if (Nb == Cb) {  
                Nb = 0;  
                printf("empty B\n");  
            }  
            Nb += Na;  
            Na = 0;  
            if (Nb > Cb) {  
                Na = Nb - Cb;  
                Nb = Cb;  
            }  
            printf("pour A B\n");  
        }  
        printf("success\n");  
    }  
    return 0;  
}  

 


补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,