当前位置:编程学习 > C/C++ >>

11044 - Searching for Nessy

 Searching for Nessy 

The Loch Ness Monsterisa mysterious and unidentified animal said to inhabit Loch Ness,
a large deep freshwaterloch near the cityof Inverness in northern Scotland. Nessie is usually categorized as a type oflake monster.
http://en.wikipedia.org/wiki/Loch_Ness_Monster

 

In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBCteam, using 600 separate sonar beams, found no trace of any ¨sea monster¨(i.e., any large animal, known or unknown) in the loch. The BBC team concludedthat Nessie does not exist. Now we want to repeat the experiment.

 

Given a grid of n rows and m columns representing the loch, 6n,m10000, find the minimum numbers of sonar beams you must put in the square such that we can control every position in thegrid, with the following conditions:


one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
the border cells do not need to be controlled, because Nessy cannot hide there (she is too big).
For example,

 

 $\textstyle \parbox{.5\textwidth}{\begin{center}\mbox{}\epsfbox{p11044.eps}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\mbox{}\epsfbox{p11044a.eps}\end{center}}$

 

\epsfbox{p11044b.eps}

 

where X represents a sonar, and the shaded cells are controlled bytheir sonar beams; the last figure gives us a solution.


Input
The first line of the input contains an integer, t, indicating the number of test cases. For eachtest case, there is a line with two numbers separated by blanks,6n,m10000, that is, the size of the grid (n rows andm columns).


Output
For each test case, the output should consist of one line showing the minimumnumber of sonars that verifies the conditions above.


Sample Input

 
3
6 6
7 7
9 13

Sample Output

 
4
4
12
[cpp]  include<stdio.h>  
int main(void) 
{    
    int t; 
    int n,m; 
    scanf("%d",&t); 
    while(t--) 
    { 
        scanf("%d%d",&n,&m); 
        printf("%d\n",(n/3)*(m/3)); 
    } 
    return 0; 

#include<stdio.h>
int main(void)

 int t;
 int n,m;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d%d",&n,&m);
  printf("%d\n",(n/3)*(m/3));
 }
 return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,