当前位置:编程学习 > C/C++ >>

HDU1047:Integer Inquiry

Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
 
 
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 
 
The final input line will contain a single zero on a line by itself.
 
 
Output
Your program should output the sum of the VeryLongIntegers given in the input. 
 
 
This problem contains multiple test cases!
 
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
 
The output format consists of N output blocks. There is a blank line between output blocks.
 
 
Sample Input
1
 
 
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
 
 
Sample Output
370370367037037036703703703670
 
 
 
 
 
 
//1002题的改版,注意下格式就好了
 
 
 
[cpp] 
#include <iostream>  
#include <cstdio>  
#include <string.h>  
using namespace std;  
  
#define N 105  
  
int main()  
{  
    void add(char a[],char b[],char c[]);  
    char a[N],b[N],sum[N];  
    int n;  
    cin >> n;  
    getchar();  
    while(n--)  
    {  
        strcpy(sum,"0");  
        while(1)  
        {  
            scanf("%s",a);  
            if(!strcmp(a,"0"))  
            break;  
            add(a,sum,sum);  
        }  
        printf("%s\n",sum);  
        if(n)  
        cout << endl;  
    }  
  
    return 0;  
}  
  
void add(char a[],char b[],char c[])  
{  
    int i,e,d;  
    int n,m;  
    char temp;  
    n=strlen(a);  
    m=strlen(b);  
    for(i=0; i<n/2; i++)  
    {  
        temp=a[i];  
        a[i]=a[n-1-i];  
        a[n-1-i]=temp;  
    }//将a倒置,另外倒置可以写成另外的函数以便节省代码量,后面多次调用  
    for(i=0; i<m/2; i++)  
    {  
        temp=b[i];  
        b[i]=b[m-1-i];  
        b[m-1-i]=temp;  
    }//将b倒置  
  
    e=0;  
    for(i=0; i<n&&i<m; i++)  
    {  
        d=a[i]-'0'+b[i]-'0'+e;  
        e=d/10;  
        c[i]=d%10+'0';  
    }//进行模拟加法  
    if(i<m)  
    {  
        for(; i<m; i++)  
        {  
            d=b[i]-'0'+e;  
            e=d/10;  
            c[i]=d%10+'0';  
        }  
    }  
    else  
    {  
        for(; i<n; i++)  
        {  
            d=a[i]-'0'+e;  
            e=d/10;  
            c[i]=d%10+'0';  
        }  www.zzzyk.com
    }//如果有一个数的位数较多,特殊处理  
    if(e) c[i++]=e+'0';//处理最后一位可以进位的情况  
    c[i]=0;  
    n=i;  
  
    for(i=0; i<n/2; i++)  
    {  
        temp=c[i];  
        c[i]=c[n-1-i];  
        c[n-1-i]=temp;  
    }//倒置  
}  
 
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,