当前位置:编程学习 > C/C++ >>

HDU 1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

我勒个去,差点被虐死,这么简单的题,开始我写的一个内联函数max和algorithm里面的函数写得不一样
交3次才AC,WA的我给你们几个数据:
0001 1000
0 0
000 0000
9999 1
1 9999
99900 00999
00999 99900
这几个数据和样例全过的话,应该可以AC了

LANGUAGE:C++
CODE:
#include<stdio.h> 
#include<string.h> 
#include<algorithm> 
#include<stdlib.h> 
 
#define maxn 1005 
 
using namespace std; 
 
char ans[maxn]; 
int anslen; 
 
void plus(char s1[],char s2[]) 

    int len1=strlen(s1); 
    int len2=strlen(s2); 
 
    for(int i=0;i<len1;i++) 
        s1[i]-='0'; 
    for(int i=0;i<len2;i++) 
        s2[i]-='0'; 
 
    int mid1=len1>>1; 
    int mid2=len2>>1; 
 
    //printf("%d %d %d %d\n",len1,len2,mid1,mid2); 
 
    for(int i=0;i<mid1;i++) 
        swap(s1[i],s1[len1-1-i]); 
    for(int i=0;i<mid2;i++) 
        swap(s2[i],s2[len2-1-i]); 
 
    anslen=max(len1,len2); 
     
    //printf("\n anslen= %d\n",anslen); 
 
    int s=0,sum; 
    for(int i=0;i<=anslen;i++) 
    { 
        sum=(s1[i]+s2[i]+s); 
        ans[i]=sum%10; 
        s=sum/10; 
    } 

 
void printans(char ans[],int anslen) 

    //if(ans[anslen+1]==0) 
    while(anslen>0&&(ans[anslen]==0))anslen--; 
    //else printf("%d",ans[anslen+1]); 
    if(anslen==0) 
    { 
        printf("%d\n",ans[0]); 
        return; 
    } 
    for(int i=anslen;i>-1;i--) 
    { 
        printf("%d",ans[i]); 
    } 
    printf("\n"); 

 
int main() 

    int cas; 
    char s1[maxn],s2[maxn]; 
    scanf("%d",&cas); 
    for(int i=1;i<=cas;i++) 
    { 
        memset(s1,0,sizeof(s1)); 
        memset(s2,0,sizeof(s2)); 
        scanf("%s%s",s1,s2); 
        printf("Case %d:\n",i); 
        printf("%s + %s = ",s1,s2); 
        plus(s1,s2); 
        printans(ans,anslen); 
        if(i!=cas)printf("\n"); 
    } 
    return 0; 

 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,