当前位置:编程学习 > C/C++ >>

POJ 1611 The Suspects

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 16509 Accepted: 7920
Description
 
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
 
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
 
For each case, output the number of suspects in one line.
Sample Input
 
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
 
4
1
1
Source
 
Asia Kaohsiung 2003
 
这道题目的数据好像是有些弱,数据中不包含 以下这种情况
 
100 3
 
4 1 2 3 4
 
2 1 6
 
1 0
 
这道题目应该是输出1的,但是我的代码输出了5竟然对了,尽管对了,我还是改了改代码,这题的主要思路我是用并查集做的
 
本该WA的代码:
 
[cpp]  
#include <iostream>  
#include <cstring>  
using namespace std;  
int a[31000];  
struct num  
{  
    int end,next;  
}b[100000];  
int c[510];  
bool status[31000];  
int main()  
{  
    void build(int x,int y);  
    int find (int x);  
    int i,j,n,m,s,t,key,k;  
    int x,y,sum;  
    while(cin>>n>>m)  
    {  
        if(!n&&!m)  
        {  
            break;  
        }  
        for(i=1;i<=n+m;i++)  
        {  
            a[i]=i;  
        }  
        memset(c,-1,sizeof(c));  
        memset(status,true,sizeof(status));  
        key=0;  
        for(i=1,y=0;i<=m;i++)  
        {  
            cin>>s;  
            for(j=1;j<=s;j++)  
            {  
                cin>>x;  
                if(x==0)  
                {  
                    key=1;  
                }  
                b[y].end=x+1; b[y].next=c[i];  
                c[i]=y; y++;  
                build(x+1+m,i);  
            }  
        }  
        if(!key)  
        {  
            cout<<1<<endl;  
            continue;  
        }  
        k=find(1+m);  
        sum=0;  
        for(i=c[k];i!=-1;i=b[i].next)  
        {  
            if(status[b[i].end])  
            {  
                sum++;  
                status[b[i].end]=false;  
            }  
        }  
        for(i=1;i<=m;i++)  
        {  
            if(a[i]!=i)  
            {  
                for(j=c[i];j!=-1;j=b[j].next)  
                {  
                    if(status[b[j].end])  
                    {  
                        sum++;  
                        status[b[j].end]=false;  
                    }  
                }  
            }  
        }  
        cout<<sum<<endl;  
    }  
    return 0;  
}  
int find(int x)  
{  
    int k1,k2;  
    k1=x;  
    while(a[x]!=x)  
    {  
        x=a[x];  
    }  
    while(k1!=a[k1])  
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,