当前位置:编程学习 > C/C++ >>

hdu3951 Coin Game

Coin Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 972 Accepted Submission(s): 592
 
 
Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.
 
 
The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 
Your job is to find out who will definitely win the game.
 
Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=109,1<=K<=10).
 
Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 
Sample Input
2
3 1
3 2
 
Sample Output
Case 1: first
Case 2: second
 
Author
NotOnlySuccess
如果,第一个人,没有把一个环都取走,那么就化环成线了,第二个人,可以了中间的,就形成了对称的两段就可以保证能胜了,但是有一个情况每二个人,不能取到中间的,就是形成了线之后的如果是偶数个,但是k为1,所以这种情况单独分类就可以了,这种情况也简单 只要比是奇还是偶就可 以了!
 
#include <iostream>  
#include <stdio.h>  
#include <string.h>  
using namespace std;  
  
int main()  
{  
    int n,k,tcase,tt=1;  
    scanf("%d",&tcase);  
    while(tcase--){  
        scanf("%d%d",&n,&k);  
        printf("Case %d: ",tt++);  
        if(n<=k)printf("first\n");  
        else {  
            if(k>=2)  
            printf("second\n");  
            else {  
              if((n-1)&1)  
                 printf("second\n");  
              else  
                printf("first\n");  
            }  
        }  
  
    }  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,