当前位置:编程学习 > C/C++ >>

POJ2182:Lost Cows(单点)

Description
 
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 
 
Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 
 
Given this data, tell FJ the exact ordering of the cows. 
Input
 
* Line 1: A single integer, N 
 
* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 
Output
 
* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
Sample Input
 
5
1
2
1
0
Sample Output
 
2
4
5
3
1
 
题意:给出的数字表示从第2到第n只牛左边有几个比它序号小的牛,要求每个位置的牛的编号是多少
思路:这道题其实和POJ2828有点相似,因为最后一个牛的编号是可以确定的,必定是k+1,然后我们可以根据这个规律进行逆推,线段树存储的是每个区间内还有几个空位
 
 
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
  
int n,ans[1000000],s[1000000];  
  
struct node  
{  
    int l,r,n;  
} a[1000000];  
  
void init(int l,int r,int i)  
{  
    a[i].l = l;  
    a[i].r = r;  
    a[i].n = r-l+1;//该区间内能放的数字个数  
    if(l!=r)  
    {  
        int mid = (l+r)/2;  
        init(l,mid,2*i);  
        init(mid+1,r,2*i+1);  
    }  
}  
  
int insert(int i,int x)  
{  
    a[i].n--;  
    if(a[i].l == a[i].r)  
        return a[i].l;  
    if(a[2*i].n>=x)//左子树的数字足够,则走左子树  
        insert(2*i,x);  
    else//否则走右子树,并且将子树视为新树,编号从1开始  
        insert(2*i+1,x-a[2*i].n);  
}  
  
int main()  
{  
    int i,j;  
    while(~scanf("%d",&n))  
    {  
        s[1] = 0;  
        for(i = 2; i<=n; i++)  
            scanf("%d",&s[i]);  
        init(1,n,1);  
        for(i = n; i>=1; i--)//逆推  
            ans[i] = insert(1,s[i]+1);  
        for(i = 1; i<=n; i++)  
            printf("%d\n",ans[i]);  
    }  
  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,