当前位置:编程学习 > C/C++ >>

hdu4055 Number String

Number String
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1027 Accepted Submission(s): 448
 
 
Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".
 
Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.
 
Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
 
Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.
 
Each test case occupies exactly one single line, without leading or trailing spaces.
 
Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.
 
Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
 
Sample Input
II
ID
DI
DD
?D
??
 
Sample Output
1
2
2
1
3
6
Hint
 
Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.
 
 
Author
HONG, Qize
 
Source
2011 Asia Dalian Regional Contest
 
Recommend
lcy
很明显的dp,我们可以得到壮态转移方程 ,如果是增dp[i][j]=sum(dp[i-1][1-j-1]),如果是减 ,我们可以 得到dp[i][j]=sum(dp[i-1][j-i-1]);这样,马上就可以得出结果了!
#include <iostream>  
#include <stdio.h>  
#include <string.h>  
#define mod 1000000007  
using namespace std;  
char str[1050];  
int dp[1050][1050],sum[1050][1050];  
int main()  
{  
    int i,j;  
   while(scanf("%s",str)!=EOF)  
   {  
       memset(dp,0,sizeof(dp));  
       sum[1][1]=1;  
       int strnum=strlen(str);  
       for(i=2;i<=strnum+1;i++)  
       {  
            for(j=1;j<=i;j++)  
               {  
                     if(str[i-2]=='I'||str[i-2]=='?')  
                   {  
  
                           dp[i][j]=(dp[i][j]+sum[i-1][j-1])%mod;  
                   }  
                    if(str[i-2]=='D'||str[i-2]=='?')  
                   {  
  
                     dp[i][j]=(dp[i][j]+((sum[i-1][i-1]-sum[i-1][j-1])%mod+mod)%mod)%mod;  
  
                   }  
                   sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;  
               }  
        }  
        printf("%d\n",sum[strnum+1][strnum+1]);  
   }  
    return 0;  
}  

 


补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,