当前位置:软件学习 > Word >>

ZOJ 1729(Hidden Password-最小表示法)

Hidden Password
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Some time the programmers have very strange ways to hide their passwords. See for example how Billy "Hacker" Geits hide his password. Billy chooses a string S composed of small Latin letters with length L. Then he makes all L-1 one-letter left cyclic shifts of the string and takes as a password one prefix of the lexicographically first of the obtained strings (including S). For example let consider the string alabala. The cyclic one-letter left shifts (including the initial string) are:
alabala
labalaa
abalaal
balaala
alaalab
laalaba
aalabal
and lexicographically first of them is the string aalabal. The first letter of this string is in position 6 in the initial string (the positions in the string are counted from 0).
Write a program that for given string S finds the start position of the smallest lexicographically one-letter left cyclic shift of this string. If the smallest lexicographically left shift appears more than once then the program have to output the smallest initial position.
Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each of the following T lines will describe one test case - first the length L of the string (5 <= L <= 100000) and then, separated by one space, the string S itself.
The output file have to contain exactly T lines with a single number each - the initial position found by your program.
 
Sample Input
2
6 baabaa
7 alabala
 
Sample Output
1
6
 
 
裸的最小表示法
 
 
#include<cstdio>  
#include<cstdlib>  
#include<cstring>  
#include<iostream>  
#include<algorithm>  
#include<functional>  
#include<cmath>  
#include<cctype>  
#include<cassert>  
#include<climits>  
using namespace std;  
#define For(i,n) for(int i=1;i<=n;i++)  
#define Rep(i,n) for(int i=0;i<n;i++)  
#define Fork(i,k,n) for(int i=k;i<=n;i++)  
#define ForD(i,n) for(int i=n;i;i--)  
#define Forp(x) for(int p=pre[x];p;p=next[p])  
#define RepD(i,n) for(int i=n;i>=0;i--)  
#define MEM(a) memset(a,0,sizeof(a))  
#define MEMI(a) memset(a,127,sizeof(a))  
#define MEMi(a) memset(a,128,sizeof(a))  
#define INF (2139062143)  
#define F (1000000009)  
#define MAXN (5000000+10)  
typedef long long ll;  
int T,n;  
char s[MAXN*2];  
int main()  
{  
   cin>>T;  
   while (T--)  
   {  
        
      scanf("%d%s",&n,s+1);  
      copy(s+1,s+1+n+1,s+n+1);  
      int i=1,j=2;  
      for(int k=0;k<=n&&i<=n&&j<=n;)  
      {  
           if (s[i+k]==s[j+k]) k++;  
           else   
         {  
            if (s[i+k]>s[j+k]) i=i+k+1;  
            else j=j+k+1;  
               if(i==j) j++;  
               k=0;  
         }  
      }  
      cout<<min(i,j)-1<<endl;  
   }  
   return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,